Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 28, 2025 - 23:00 EDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Mar 26, 2025 - 14:27 EDT
Scheduled
GeorgiaFIRST and Augusta University PeopleSoft Financials will be unavailable from 11:00 p.m. on Friday, March 28, 2025, until 12:30 p.m. on Saturday, March 29, 2025, for the application of Releases 6.04 for GeorgiaFIRST and 2.02 for Augusta University.
The following applications will not be available during this scheduled maintenance window:
· GeorgiaFIRST PeopleSoft Financials production (FPROD) · Augusta University PeopleSoft Financials production (AUFPROD) · PSQUEST access · GeorgiaFIRST Marketplace access · Expenses and ePro Self-Service Portal · Health eShop access
Posted Mar 21, 2025 - 14:51 EDT
This scheduled maintenance affected: GeorgiaFIRST Financials (GeorgiaFIRST PeopleSoft Financials, GeorgiaFIRST Marketplace) and Augusta University Financials (Augusta University Financials, Augusta Health eShop).