SYSTEMS STATUS
GeorgiaBEST Banner Managed Services - University of West Georgia
Incident Report for USG Services
Resolved
After monitoring the situation, Information Technology Services (ITS) has confirmed the stability of GeorgiaBEST Managed Services at University of West Georgia. The system should continue operating normally.

In the event that you experience any further issues with access to GeorgiaBEST Managed Services, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001
Posted Apr 10, 2024 - 08:47 EDT
Identified
University of West Georgia is now live with Self-Service Banner (SSB). Please use the tiles found in OneLogin under "Student Resources" and
"Employee Resources".
Posted Mar 25, 2024 - 10:41 EDT
This incident affected: GeorgiaBEST Banner Managed Services (University of West Georgia).