SYSTEMS STATUS
GeorgiaBEST Managed Services Issue Reported
Incident Report for USG Services
Resolved
After monitoring the situation, Information Technology Services (ITS) has confirmed the stability of Banner and Self-Service Banner access. The system should continue operating normally.

In the event that you experience any further issues with Banner access, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted Nov 30, 2023 - 08:48 EST
Monitoring
Information Technology Services (ITS) is currently monitoring reports of issues with GeorgiaBEST Managed Services. Affected users may have been experiencing connectivity issues with Banner and Self-Service Banner. Full functionality appears to have been restored and additional information will be posted here. We will continue to monitor this system for stability. If you are still experiencing issues with GeorgiaBEST Managed Services, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted Nov 29, 2023 - 15:01 EST
This incident affected: GeorgiaBEST Banner Managed Services (Abraham Baldwin Agricultural College, Albany State University, Atlanta Metropolitan State College, Clayton State University, College of Coastal Georgia, Columbus State University, Dalton State College, East Georgia State College, Fort Valley State University, Georgia College and State University, Georgia Gwinnett College, Georgia Southern University, Georgia Southwestern State University, Gordon State College, Middle Georgia State University, Savannah State University, South Georgia State College, University of West Georgia, Valdosta State University).