SYSTEMS STATUS
GeorgiaBEST Banner Managed Services - Fort Valley State University
Incident Report for USG Services
Resolved
After monitoring the situation, Information Technology Services (ITS) has confirmed the stability of GeorgiaBEST Managed Services at Fort Valley State University. The system should continue operating normally.

In the event that you experience any further issues with access to GeorgiaBEST Managed Services, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001
Posted Apr 15, 2024 - 10:25 EDT
Identified
Fort Valley State University (FVSU) is now live with Self-Service Banner 9 (SSB9). Please use the new tile on the MyApps portal page.
Posted Mar 15, 2024 - 17:17 EDT
This incident affected: GeorgiaBEST Banner Managed Services (Fort Valley State University).