SYSTEMS STATUS

Network Outage - Georgia Institute of Technology

Incident Report for USG Services

Resolved

After monitoring the situation, Information Technology Services (ITS) has confirmed the stability of network access at the Georgia Institute of Technology. The system should continue operating normally.

In the event that you experience any further issues with network access, please contact the USG Service Desk at support@usg.edu or 877-251-2644.
Posted Dec 02, 2025 - 15:15 EST

Investigating

Information Technology Services (ITS) is currently investigating reports of service interruptions with network services at Georgia Institute of Technology.

Additional information will be posted here when it becomes available.


Zayo: TTN-0009286461

Circuit: FBDK/562465//ZFS
Posted Dec 01, 2025 - 14:59 EST
This incident affected: PeachNet Network (Georgia Institute of Technology).