SYSTEMS STATUS
USO Internal Services Issues Reported - Microsoft Outlook Web Client
Incident Report for USG Services
Resolved
Information Technology Services (ITS) has confirmed that Microsoft has resolved the login issue with Outlook webmail and access to webmail is functioning normally at this time.

In the event that you experience any further issues with logging into webmail, please contact the ITS Helpdesk at: helpdesk@usg.edu or 706-583-2001.
Posted May 14, 2020 - 10:34 EDT
Investigating
Information Technology Services (ITS) is reporting that users may be unable to log into Outlook webmail from any browser. Microsoft is currently investigating a potential issue and checking for impact.

Updates will be posted here as they become available.
Posted May 13, 2020 - 15:16 EDT
This incident affected: Internal USO Services (USO Email and Calendar).