Information Technology Services (ITS) has confirmed that the Albany State University East Campus router is functioning normally at this time.
In the event that you experience any further issues with network access, please contact the USG Service Desk at support@usg.edu or 877-251-2644.
Posted Jul 09, 2025 - 08:13 EDT
Monitoring
The router at Albany State University's East Campus has been replaced. We will continue to monitor this system for stability. If you are still experiencing issues with network access, please contact the USG Service Desk at support@usg.edu or 877-251-2644.
Posted Jul 09, 2025 - 01:37 EDT
Update
The ETA for the technician is 12:30 a.m.
Posted Jul 08, 2025 - 22:41 EDT
Identified
A new router is with Communications Consulting Group (CCG) and is in the process of being replaced.
Posted Jul 08, 2025 - 22:03 EDT
Investigating
Information Technology Services (ITS) is currently investigating network issues at Albany State University East Campus. Affected users may be experiencing problems with accessing the network.
Posted Jul 08, 2025 - 18:39 EDT
This incident affected: PeachNet Network (Albany State University) and GeorgiaVIEW Online Learning (Albany State University (QPROD)).