SYSTEMS STATUS
USG Technology Store Issues Reported
Incident Report for USG Services
Resolved
The USG Technology Store is operating as normal and customers can now access both sides of the web store.

In the event that you experience any further issues with the USG Technology Store, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted Sep 06, 2024 - 08:31 EDT
Identified
The USG Technology Store is currently experiencing technical issues affecting the "For Work" side of the USG Technology Store webpage, techstore.usg.edu. Student access is available.

Users may encounter the error:
"Sorry! You have no permission to view this page.
Please contact the website administrator, click here to continue."

USG Support Staff are currently working with the vendor to resolve and mitigate this issue.

Additional information will be posted here as it becomes available.

In the meantime, if you have any questions or need assistance with a transaction, please email us at techstore@usg.edu
Posted Aug 22, 2024 - 16:14 EDT
This incident affected: USG Technology Store.