Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 27, 2024 - 17:30 EDT
Scheduled
Information Technology Services (ITS) will be completing maintenance in Banner Production environments on Friday, September 27, 2024, from 5:30 p.m. until Saturday, September 28, 2024, at 7:00 a.m.
Banner Managed Services databases will be unavailable during this maintenance period.
The following schools are impacted:
- Abraham Baldwin Agricultural College - Albany State University - Dalton State College - East Georgia State College - Georgia College and State University - Georgia Southern University - Georgia Southwestern State University - Savannah State University - South Georgia State College
Posted Sep 19, 2024 - 11:06 EDT
This scheduled maintenance affected: GeorgiaBEST Banner Managed Services (Abraham Baldwin Agricultural College, Albany State University, Dalton State College, East Georgia State College, Georgia College and State University, Georgia Southern University, Georgia Southwestern State University, Savannah State University, South Georgia State College).