SYSTEMS STATUS

Multi-Site Windstream Outage

Incident Report for USG Services

Resolved

Network Support Services (NSS) and Zayo/ENA have confirmed that Windstream has restored full functionality of internet access at the affected schools.

In the event that you experience any further issues with network access, please contact the USG Service Desk at support@usg.edu or 877-251-2644.
Posted Apr 03, 2026 - 08:27 EDT

Identified

The Windstream field technician has identified the damage location in Dawson, GA, which was caused by an auto accident. Appropriate repair teams are being engaged to proceed with restoration efforts.
Posted Apr 01, 2026 - 09:29 EDT

Investigating

Information Technology Services (ITS) is reporting a multi-site Windstream outage affecting the following locations:

- Clay County Schools
- Marion County Schools
- Terrell County Schools
- Terrell RYDC

Zayo/ENA is investigating the root cause of the disruptions. There is currently no ETR for resolving the issue, but updates will be posted as they become available.
Posted Apr 01, 2026 - 08:34 EDT
This incident affected: GA DOE K-12 Network.