Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 29, 2026 - 17:30 EST
Scheduled
Information Technology Services (ITS) will be installing Banner Baseline Patches and upgrades in Banner Production environments for the following schools on Thursday, January 29, 2026, beginning at the times listed below through Friday, January 30th, 2026, at 7:00 a.m.
The institutions and downtimes are below:
* College of Coastal Georgia beginning at 9:00 p.m. * Columbus State University beginning at 11:00 p.m. * Dalton State University beginning at 7:00 p.m. * East Georgia State University beginning at 5:30 p.m. * Fort Valley State University beginning at 8:00 p.m. * Georgia Southwestern State University beginning at 5:30 p.m. * Gordon State College beginning at 7:00 p.m. * Middle Georgia State University beginning at 6:30 p.m. * Savannah State University beginning at 5:30 p.m. * Valdosta State University beginning at 11:00 p.m.
Posted Jan 29, 2026 - 16:43 EST
This scheduled maintenance affected: GeorgiaBEST Banner Managed Services (College of Coastal Georgia, Columbus State University, Dalton State College, Georgia Southern University – East Georgia Campus, Fort Valley State University, Georgia Southwestern State University, Gordon State College, Middle Georgia State University, Savannah State University, Valdosta State University).