SYSTEMS STATUS

Multi-Site Planter Telephone Outage

Incident Report for USG Services

Identified

Planter Telephone is investigating a fiber cut in Covington, GA, there is no ETR available.
Posted Sep 23, 2026 - 16:11 EDT

Update

We are continuing to investigate this issue.
Posted Sep 23, 2026 - 16:08 EDT

Investigating

Network Support Services (NSS) is currently investigating a multi-site outage affecting Planter Telephone locations. Zayo is currently investigating the issue.

Updates will be posted here as they become available.

Sites Affected:

- Camden County Schools

- Screven County Schools

- Lincoln County Schools

- Burke County Schools

- Taliaferro County Schools

- Wilkes County Schools

- Bryan County Schools

- Candler County Schools

- Jenkins County Schools

- Bulloch County Schools
Posted Sep 23, 2026 - 14:22 EDT
This incident affects: GA DOE K-12 Network.