After monitoring the situation, Information Technology Services (ITS) has confirmed the stability of GeorgiaFIRST Financials and Augusta University Financials. The system should continue operating normally.
In the event that you experience any further issues with access to GeorgiaFIRST Financials and Augusta University Financials, please contact the USG Service Desk at support@usg.edu or 877-251-2644.
Posted Feb 11, 2025 - 17:28 EST
Monitoring
Information Technology Services (ITS) has restored full functionality of GeorgiaFIRST Financials and Augusta University Financials. We will continue to monitor this system for stability. If you are still experiencing issues with access to GeorgiaFIRST Financials and Augusta University Financials, please contact the USG Service Desk at support@usg.edu or 877-251-2644.
Posted Feb 11, 2025 - 12:57 EST
Investigating
Information Technology Services (ITS) is currently investigating reports of issues with access to GeorgiaFIRST Financials and Augusta University Financials. Affected users may be experiencing problems with access.
Additional information will be posted here as it becomes available.
Posted Feb 11, 2025 - 12:25 EST
This incident affected: GeorgiaFIRST Financials (GeorgiaFIRST PeopleSoft Financials, GeorgiaFIRST Marketplace, FPLAY, GeorgiaFIRST Marketplace UIT) and Augusta University Financials (Augusta University Financials, Augusta Health eShop, AUFPLAY).