SYSTEMS STATUS
GIL Express Courier Service Schedule: Monday, October 12, 2020
Incident Report for USG Services
Resolved
This incident has been resolved. Pick up and deliveries are back to normal.
Posted Oct 12, 2020 - 16:47 EDT
Identified
In observance of Columbus Day, STAT Courier will not be making deliveries or pickups on Monday, October 12, 2020.
Posted Oct 09, 2020 - 13:06 EDT
This incident affected: GALILEO - Georgia's Virtual Library (GIL Express).