SYSTEMS STATUS
GeorgiaBEST Managed Services Issues Reported - Georgia Gwinnett College
Incident Report for USG Services
Resolved
After monitoring the situation, Information Technology Services (ITS) has confirmed the stability of GeorgiaBEST Managed Services for Georgia Gwinnett College. The system should continue operating normally.

In the event that you experience any further issues with GeorgiaBEST Managed Services, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted Nov 01, 2019 - 09:03 EDT
Monitoring
Information Technology Services (ITS) has restored the full functionality of Georgia Gwinnett College's GeorgiaBEST Managed Services. We will continue to monitor this system for stability. If you are still experiencing issues with Service Invocation Failed errors and issues with accessing Application Navigator or College Scheduler, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted Oct 30, 2019 - 10:40 EDT
Investigating
Information Technology Services (ITS) is currently investigating reports of issues with GeorgiaBEST Managed Services. Affected users may be experiencing Service Invocation Failed errors, the inability to access Application Navigator, and College Scheduler.

Additional information will be posted here when the issues are confirmed.
Posted Oct 29, 2019 - 14:53 EDT
This incident affected: GeorgiaBEST Banner Managed Services (Georgia Gwinnett College).