SYSTEMS STATUS
Intermittent Issues - Armstrong Atlantic State (ARM2) - SouthEast Ring
Incident Report for USG Services
Monitoring
Full functionality of network access has been restored. We will continue to monitor this system for stability. If you are still experiencing issues with intermittent network access, please contact the USG Service Desk at support@usg.edu or 877-251-2644.
Posted Jan 03, 2025 - 12:15 EST
Investigating
ARM2 (Armstrong Atlantic State) has been having intermittent issues and is being investigated at this time.

Where: SouthEast Ring
Posted Dec 30, 2024 - 15:34 EST
This incident affects: PeachNet Network (Georgia Southern University).