SYSTEMS STATUS
Power Outage - Savannah State University
Incident Report for USG Services
Resolved
The power at Savannah State University (SAV.RTR) has been restored and services have returned.
Posted Aug 06, 2024 - 10:10 EDT
Monitoring
The power at Savannah State University has been restored and services have returned.
Posted Aug 06, 2024 - 08:06 EDT
Identified
Information Technology Services (ITS) is reporting a power outage affecting Savannah State University (SAV.RTR). It appears the site lost power due to the storms. Affected users may be experiencing problems with access to the internet. Updates will be posted here as they become available.
Posted Aug 06, 2024 - 00:26 EDT
This incident affected: GeorgiaVIEW Online Learning (Savannah State University (QPROD)) and PeachNet Network (Savannah State University).