Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 25, 2024 - 17:30 EDT
Scheduled
Information Technology Services (ITS) will be completing maintenance in Banner Production environments on Friday, October 25, 2024, from 5:30 p.m. until Saturday, October 26, 2024, at 7:00 a.m.
Banner Managed Services databases will be unavailable during this maintenance period.
The following schools are impacted:
- Abraham Baldwin Agricultural College - Albany State University - College of Coastal Georgia - East Georgia State College - Georgia Southern University - Savannah State University - South Georgia State College
Posted Oct 25, 2024 - 13:42 EDT
This scheduled maintenance affected: GeorgiaBEST Banner Managed Services (Abraham Baldwin Agricultural College, Albany State University, College of Coastal Georgia, East Georgia State College, Georgia Southern University, Savannah State University, South Georgia State College).