SYSTEMS STATUS
Scheduled PeachNet Maintenance - North Ring
Scheduled for Dec 9, 09:00 - 16:00 EST
Update
We will be undergoing scheduled maintenance during this time.
Posted Nov 25, 2024 - 16:12 EST
Scheduled
ZAYO and Network Support Services (NSS) will be performing maintenance on the North Ring. This maintenance will occur on Monday, January 8, 2025, at 9:00 a.m. until 4:00 p.m. No outages are expected, but services will run in protect.

Zayo: TTN-0008154159
Posted Nov 05, 2024 - 15:11 EST
This scheduled maintenance affects: PeachNet Network (USO Athens Office).