SYSTEMS STATUS

Augusta University Authentication Issues Reported

Incident Report for USG Services

Resolved

After monitoring the situation, Information Technology Services (ITS) has confirmed that the network for Augusta University is back online. Brightspace should be accessible via SSO at this time.

In the event that you experience any further issues with access to GeorgiaVIEW, please contact the USG Service Desk at support@usg.edu or 877-251-2644.
Posted Aug 03, 2026 - 13:57 EDT

Monitoring

Information Technology Services (ITS) has confirmed that the network for Augusta University is back online. Brightspace should be accessible via SSO at this time. We are continuing to monitor the system for stability.

Affected area:

- GeorgiaVIEW Online Learning Environment - Augusta University
Posted Jul 30, 2026 - 11:52 EDT

Investigating

Information Technology Services (ITS) is currently investigating a local campus login issue for Augusta University. Affected users may be experiencing problems accessing Brightspace. Additional information will be posted here when the issues are confirmed.

Affected area:

- GeorgiaVIEW Online Learning Environment - Augusta University
Posted Jul 30, 2026 - 09:03 EDT
This incident affected: GeorgiaVIEW Online Learning (Augusta University).