SYSTEMS STATUS

East Georgia State College - Banner Application Navigation Down

Incident Report for USG Services

Resolved

Information Technology Services (ITS) has monitored for stability and confirmed that GeorgiaBEST Managed Services is functioning normally at this time.

In the event that you experience any further issues with access to GeorgiaBEST Managed Services, please contact the USG Service Desk at support@usg.edu or 877-251-2644.
Posted May 02, 2025 - 13:54 EDT

Monitoring

Information Technology Services (ITS) has restored functionality to the Banner Application Navigation, and currently monitoring for stability.

If you are still experiencing issues with GeorgiaBEST Banner Managed Services, please contact the USG Service Desk at support@usg.edu or 877-251-2644
Posted May 02, 2025 - 12:12 EDT

Investigating

East Georgia State College has reported that Banner Application Navigator is down. Self-Service Banner applications are still accessible and not impacted by this outage. Information Technology Services (ITS) is investigating. Updates will be posted here as they become available.
Posted May 02, 2025 - 10:55 EDT
This incident affected: GeorgiaBEST Banner Managed Services (East Georgia State College).