SYSTEMS STATUS

Network Outage - Kennesaw State University - Marietta Campus

Incident Report for USG Services

Resolved

Information Technology Services (ITS) has confirmed that the gas leak has been repaired and services have been restored at Kennesaw State University - Marietta Campus.
Posted Dec 03, 2025 - 08:28 EST

Update

Information Technology Services (ITS) is reporting that services are estimated to be restored no sooner than 5:00 p.m.
Posted Dec 02, 2025 - 15:26 EST

Identified

Kennesaw State University (KSU) reports that this second outage is expected as crews continue their repairs on the gas leak.
Posted Dec 02, 2025 - 03:24 EST

Investigating

Information Technology Services (ITS) is currently investigating reports of issues affecting network access at Kennesaw State University - Marietta Campus. Affected users may be experiencing problems accessing the internet.

Additional information will be posted here when it becomes available.
Posted Dec 02, 2025 - 03:22 EST
This incident affected: PeachNet Network (Kennesaw State University).