SYSTEMS STATUS
OneUSG Connect Benefits - Retirement@Work Website is Down
Incident Report for USG Services
Resolved
Teachers Insurance and Annuity Association of America (TIAA) has confirmed that the Retirement@Work website is functioning normally at this time.

In the event that you experience any further issues with the Retirement@Work website, please contact OneUSG Connect Support at oneusgsupport@usg.edu.
Posted Nov 21, 2019 - 09:55 EST
Investigating
Teachers Insurance and Annuity Association of America (TIAA) reports that their Retirement@Work website is not accessible at this time. Some employees may be able to log in via employee self-service but may not be able to see all of their information. TIAA is actively working on resolving the issue.

More Information and Support: Contact OneUSG Connect Support at oneusgsupport@usg.edu.
Posted Nov 19, 2019 - 11:39 EST
This incident affected: OneUSG Connect (OneUSG Connect – Core Practitioner).