SYSTEMS STATUS
Mitel Phone System Issues Reported
Incident Report for USG Services
Resolved
After monitoring the situation, Information Technology Services (ITS) has confirmed the stability of the Mitel phone system. The system should continue operating normally.

In the event that you experience any further issues with Mitel, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted Jun 24, 2024 - 11:19 EDT
Monitoring
Information Technology Services (ITS) has restored full functionality of the Mitel phone system. We will continue to monitor this system for stability. If you are still experiencing issues with Mitel phones, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted Jun 20, 2024 - 15:04 EDT
Investigating
Information Technology Services (ITS) is currently investigating reports of an issue with the phone system. Affected users can submit a support request via Email at: helpdesk@usg.edu, Email: oneusgsupport@usg.edu, or via Self Service at: https://usg.service-now.com/usgsp

If your matter is of an urgent nature, please contact the ITS Helpdesk after-hours on call phone at 404-831-3669.
Posted Jun 20, 2024 - 08:17 EDT
This incident affected: PeachNet Network (USO Athens Office, USO Atlanta Office, USO Shared Services Center).