SYSTEMS STATUS

D2L Impacting Event Notification - D2L Help Center

Incident Report for USG Services

Resolved

D2L has confirmed that D2L Help Center is functioning normally at this time.

In the event that you experience any further issues with D2L Help Center, please contact the USG Service Desk at support@usg.edu or 877-251-2644.
Posted Sep 17, 2026 - 12:39 EDT

Monitoring

D2L has restored full functionality of D2L Help Center access. If you are still experiencing issues with D2L, please contact the USG Service Desk at support@usg.edu or 877-251-2644.
Posted Sep 17, 2026 - 09:49 EDT

Investigating

Beginning around 6:53 a.m. today, some users may experience issues with the D2L Help Center at this address: https://d2lhelp.view.usg.edu/. Service is intermittent right now. Our vendor is actively investigating the issue and working to restore normal service. We will post additional updates as they are available.
Posted Sep 16, 2026 - 11:33 EDT
This incident affected: GeorgiaVIEW Online Learning (GeorgiaVIEW Online Learning Environment (QPROD), GeorgiaVIEW Online Learning Environment (XPROD), Augusta University, Georgia Southern University).