SYSTEMS STATUS
PeachNet Network Outage Reported - Georgia Student Finance Commission (GSFC)
Incident Report for USG Services
Resolved
After monitoring the situation, Information Technology Services (ITS) has confirmed the stability of network access at Georgia Student Finance Commission (GSFC). The system should continue operating normally.

In the event that you experience any further issues with access to the network, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted Jul 16, 2024 - 13:49 EDT
Monitoring
Communications Consulting Group (CCG) is reporting power has been restored at Georgia Student Finance Commission (GSFC). We will continue to monitor this system for stability. If you are still experiencing issues with network access, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted Jul 16, 2024 - 07:21 EDT
Investigating
Communications Consulting Group (CCG) is reporting a network outage at Georgia Student Finance Commission (GSFC) due to a power outage. ETR is currently 1:00 a.m. We will provide further details as they become available.

The following sites are currently down:

- Georgia Student Finance Commission (GSFC)
Posted Jul 15, 2024 - 22:03 EDT
This incident affected: PeachNet Network (Georgia Student Finance Commission).