SYSTEMS STATUS
GeorgiaFIRST Marketplace Issues Reported
Incident Report for USG Services
Resolved
Information Technology Services (ITS) has confirmed that E-Invoices in the GeorgiaFIRST Marketplace are no longer delayed. You may continue running your voucher build processes for current e-invoices from the GFM.

In the event that you experience any further issues with the GeorgiaFIRST Marketplace, please contact the ITS Helpdesk at: helpdesk@usg.edu or 706-583-2001.
Posted 10 days ago. Dec 05, 2017 - 16:17 EST
Investigating
E-Invoices in the GeorgiaFIRST Marketplace are currently delayed. Information Technology Services (ITS) is working with Jaggaer to fix the issue. Additional information will be posted here when it becomes available.
Posted 10 days ago. Dec 05, 2017 - 08:34 EST
This incident affected: GeorgiaFIRST Financials (GeorgiaFIRST Marketplace).