SYSTEMS STATUS
Savannah State University - D2L Server Error Issue
Incident Report for USG Services
Resolved
After monitoring the situation, Information Technology Services (ITS) has confirmed the stability of GeorgiaVIEW (Brightspace by D2L). The system should continue operating normally.

In the event that you experience any further issues with GeorgiaVIEW (Brightspace by D2L), please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted Feb 19, 2024 - 09:01 EST
Monitoring
Access to Brightspace through the Savannah State University appears to be functioning normally at this time. Information Technology Services (ITS) is continuing to monitor for additional reports.

If you are still experiencing issues with GeorgiaVIEW access, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted Feb 17, 2024 - 17:47 EST
Investigating
Information Technology Services (ITS) is currently investigating a local campus login issue for Savannah State University. Affected users may be experiencing problems with accessing GeorgiaVIEW (Brightspace by D2L).

Additional information will be posted here as updates are available.
Posted Feb 17, 2024 - 16:36 EST
This incident affected: GeorgiaVIEW Online Learning (Savannah State University (QPROD)).