SYSTEMS STATUS
ServiceNow Issues Reported
Incident Report for USG Services
Resolved
After monitoring the system for stability, ITS has confirmed that ServiceNow is functioning normally. If you experience any issues with access to ServiceNow, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted 6 days ago. May 13, 2019 - 16:02 EDT
Monitoring
The ServiceNow technical staff have resolved the connection issues. Users may need to restart their browsers to restore access to ServiceNow. Information Technology Services (ITS) will continue to monitor this system for stability. If you are still experiencing issues with access to ServiceNow, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted 6 days ago. May 13, 2019 - 11:52 EDT
Investigating
Information Technology Services (ITS) is investigating reports that some users are having issues loading pages in ServiceNow. Affected users may receive a message that "The connection was reset" while attempting to load a page.

We are currently gathering additional information about this intermittent issue. If you are affected by it, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.

Additional information will be posted here when it becomes available.
Posted 6 days ago. May 13, 2019 - 11:21 EDT
This incident affected: ServiceNow.