Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 13, 2025 - 18:00 EDT
Scheduled
Network Support Services (NSS) Telephony will be renewing the certificates for the Mitel Headquarters and Enterprise Contact Center services.
The maintenance window is scheduled for Thursday, March 13, 2025, at 6:00 p.m. until Friday, March 14, 2025, at 12:00 a.m.
Possible impact may include requiring the Mitel servers to be rebooted as part of the certificate installation process which will briefly cause an outage.
If you experience issues with making a call to the USG Service Desk main line (877-251-2644) during this maintenance, please send an email to: support@usg.edu or if your matter is of an urgent nature, please contact the USG Service Desk after-hours on call phone at 404-831-3669.
Posted Mar 12, 2025 - 10:37 EDT
This scheduled maintenance affected: PeachNet Network (USO Athens Office, USO Atlanta Office, USO Shared Services Center).