SYSTEMS STATUS

PeachNet Network Outage - University of Georgia - Rock Eagle (ROC)

Incident Report for USG Services

Resolved

Information Technology Services (ITS) has confirmed that AT&T has resolved network issues at the University of Georgia - Rock Eagle (ROC), Morgan County DOE and Jasper County DOE. Network access is functioning normally at this time.

In the event that you experience any further issues with network access, please contact the USG Service Desk at support@usg.edu or 877-251-2644.
Posted May 07, 2025 - 11:28 EDT

Investigating

Information Technology Services (ITS) is investigating an outage at University of Georgia - Rock Eagle (ROC). AT&T is working on the loss of connection to the areas. There is no ETR at this time. Updates will be posted here as they become available.

Sites affected:
- University of Georgia - Rock Eagle (ROC)
- Morgan County
- Jasper County
Posted May 06, 2025 - 16:30 EDT
This incident affected: PeachNet Network (University of Georgia).