SYSTEMS STATUS
Power Outage - South Georgia State College - Waycross Campus (WAY)
Incident Report for USG Services
Resolved
After monitoring the situation, Information Technology Services (ITS) has confirmed the stability of South Georgia State College - Waycross Campus (WAY). The system should continue operating normally.

In the event that you experience any further issues with network access, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted Oct 10, 2024 - 10:51 EDT
Update
Further updates regarding this outage will be posted under Network Outage - Multiple Campus Outage:

https://status.usg.edu/incidents/7tg2xzrz3sry
Posted Sep 28, 2024 - 13:01 EDT
Identified
Information Technology Services (ITS) is reporting a power outage affecting South Georgia State College - Waycross Campus (WAY). It appears the site lost power. Affected users may be experiencing problems with access to the internet. Updates will be posted here as they become available.
Posted Sep 27, 2024 - 03:19 EDT
This incident affected: PeachNet Network (South Georgia State College).