SYSTEMS STATUS

Multi-Site DOE Outage Reported – DOE -K-12

Incident Report for USG Services

Resolved

All services have been restored, and no further service interruptions are expected. ENA has contacted Comcast to determine the root cause of the outage and is awaiting a response.

In the event that you experience any further issues with access, please contact the USG Service Desk at: support@usg.edu or 877-251-2644.
Posted May 02, 2025 - 08:54 EDT

Investigating

Network Support Services (NSS) is reporting a multi-site DOE outage. All sites have Comcast as their last mile provider. ENA has been notified and is currently working with vendors to investigate the cause. There is no ETR currently. Updates will be provided when possible.

Sites Affected:
- DOE K-12

- Augusta RYDC
- Columbia County Board of Education
- Georgia School for Innovation and the Classics
- McDuffie County Board of Education
- ‎SAIL Charter Academy
Posted Apr 30, 2025 - 14:54 EDT
This incident affected: GA DOE K-12 Network.