SYSTEMS STATUS

Known Issue - OneUSG Connect Careers

Incident Report for USG Services

Resolved

The OneUSG Connect - Careers Portal has returned to normal functionality. There should be no more issues accessing the OneUSG Connect - Careers Portal, including posting and removing job openings.

In the event that you experience any further issues with the OneUSG Connect - Careers Portal, please contact the USG Service Desk at support@usg.edu or 877-251-2644.
Posted Sep 03, 2026 - 11:06 EDT

Identified

Users are experiencing Intermittent issues when accessing the OneUSG Connect Careers portal, including posting and removing job openings. There is no workaround at this time.

The OneUSG Connect team is working to identify the root cause and determine and resolution. We will let you know when functionality is restored.
Posted Sep 02, 2026 - 11:40 EDT
This incident affected: OneUSG Connect (OneUSG Connect- Careers Applicant Access).