SYSTEMS STATUS
PeopleSoft Login Issues
Incident Report for USG Services
Resolved
After monitoring the situation throughout the afternoon, Information Technology Services (ITS) has confirmed that the stability of PeopleSoft has been restored. The system should continue operating normally.

In the event that you experience any further issues with access to PeopleSoft, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted 15 days ago. Sep 07, 2017 - 16:22 EDT
Monitoring
Information Technology Services (ITS) was experiencing issues with logging into PeopleSoft Financials. ITS has restored full functionality of PeopleSoft and will continue to monitor this system for stability for the remainder of the day.
If you are still experiencing issues with logging into PeopleSoft, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted 15 days ago. Sep 07, 2017 - 14:25 EDT
This incident affected: GeorgiaFIRST Financials (GeorgiaFIRST PeopleSoft Financial Service).