SYSTEMS STATUS
GeorgiaFIRST PeopleSoft Financials Issues Reported
Incident Report for USG Services
Resolved
Information Technology Services (ITS) has confirmed that GeorgiaFIRST PeopleSoft Financials is functioning normally at this time.

In the event that you experience any further issues with GeorgiaFIRST PeopleSoft Financials, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted Nov 20, 2023 - 11:08 EST
Investigating
Information Technology Services (ITS) is reporting that intermittent errors may be encountered when inquiring on and/or adding Vouchers in the Accounts Payable module. More information will be posted here when it becomes available.
Posted Nov 17, 2023 - 16:25 EST
This incident affected: GeorgiaFIRST Financials (GeorgiaFIRST PeopleSoft Financials).