SYSTEMS STATUS
Hurricane Helene's Impact on GA DOE K-12 Network
Incident Report for USG Services
Resolved
After monitoring the situation Information Technology Services (ITS) has confirmed the stability of internet access for the GA DOE K-12 Network. The system should continue operating normally.

In the event that you experience any further issues with network access, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted Oct 17, 2024 - 16:07 EDT
Monitoring
Efforts to resolve all remaining outages are ongoing. Please contact us if you are still without internet access and have not been in contact with ENA.

Phone: 706-583-2001 Email: helpdesk@usg.edu
Posted Oct 10, 2024 - 10:38 EDT
Update
There are still widespread power outages and fiber cuts throughout the state of Georgia. If there are internet outages related to fiber cuts, they cannot be repaired until power in the area is restored and repair crews are hands-off.

ENA has been attempting to contact all sites that are currently without service but there are many locations that cannot be reached at this time. If your site currently has power but your internet service is still down and you have not been in contact with ENA, please reach out to us so that we can begin investigation.

Contact: helpdesk@usg.edu or 706-583-2001
Posted Sep 30, 2024 - 14:23 EDT
Identified
Due to Hurricane Helene, the GA DOE K-12 Network is experiencing multiple outages statewide. Most issues are related to power loss, with some fiber cuts expected. ENA will contact local contacts to verify the power status. Restoring power is always the top priority, followed by network and internet services. If you need help, please contact ITS at helpdesk@usg.edu or call 706-583-2001. Thank you for your understanding and cooperation during this time. Stay safe!
Posted Sep 27, 2024 - 06:09 EDT
This incident affected: GA DOE K-12 Network.