SYSTEMS STATUS
GeorgiaBEST Managed Services Issues Reported - Atlanta Metropolitan State College
Incident Report for USG Services
Resolved
After monitoring the situation, Information Technology Services (ITS) has confirmed the stability of Banner access at Atlanta Metropolitan State College. The system should continue operating normally.

In the event that you experience any further issues with access to Banner, please contact the USG Service Desk at support@usg.edu or 877-251-2644.
Posted Jan 28, 2025 - 13:57 EST
Monitoring
Information Technology Services (ITS) has restored full functionality of Banner access at Atlanta Metropolitan State College. We will continue to monitor this system for stability. If you are still experiencing issues with access to Banner, please contact the USG Service Desk at support@usg.edu or 877-251-2644.
Posted Jan 28, 2025 - 08:37 EST
Investigating
Information Technology Services (ITS) is currently investigating reports of issues with GeorgiaBEST Managed Services. Administrative Banner is not accessible at this time for Atlanta Metropolitan State College. Users may encounter a 404 error message.
Posted Jan 27, 2025 - 13:27 EST
This incident affected: GeorgiaBEST Banner Managed Services (Atlanta Metropolitan State College).