Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 02, 2025 - 23:00 EDT
Scheduled
Systems Support Services (SSS) will be performing essential maintenance to update the security certificates (SAML certificates) for our Single Sign-On (SSO) system. This maintenance will occur from Thursday, October 2, 2025, at 11:00 p.m. until Friday, October 3, 2025, at 5:00 a.m.
User Impact: During this maintenance window, users will be unable to log in to the affected services and applications listed above. Users who are already logged in before the maintenance begins should not be affected, but they will be unable to log back in if their session expires.
Service will be restored as soon as the maintenance is complete. We apologize for any inconvenience this may cause.
Services Affected:
* USO Single Sign-On (SSO) * USO VPN
Affected Applications:
* Adobe SSO * Data Warehouse and Business Intelligence - APEX * DocuSign * GeorgiaFIRST Financials * KnowBe4 * OneUSG Connect – Benefits: Alight * OneUSG Connect - Employee and Manager Self-Service * PagerDuty * ServiceNow * Smartsheet * Splunk Cloud * Tenable Cloud * Xmedius - Web Fax Service
Posted Sep 30, 2025 - 16:04 EDT
This scheduled maintenance affected: GeorgiaFIRST Financials (GeorgiaFIRST PeopleSoft Financials), Data Warehouse and Business Intelligence, ServiceNow, OneUSG Connect (OneUSG Connect – Employee and Manager Self-Service, OneUSG Connect – Benefits: Alight), and Internal USO Services (USO SSO, USO VPN).