SYSTEMS STATUS
GeorgiaBEST Managed Services Issue Reported
Incident Report for USG Services
Resolved
Information Technology Services (ITS) has confirmed that GeorgiaBEST Managed Services is functioning normally at this time.

In the event that you experience any further issues with GeorgiaBEST Managed Services, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted 2 months ago. Feb 11, 2019 - 10:24 EST
Investigating
Information Technology Services (ITS) is currently investigating reports of issues with GeorgiaBEST Managed Services. Affected users may be experiencing problems logging in. Additional information will be posted here when the issues are confirmed.
Posted 2 months ago. Feb 11, 2019 - 09:16 EST
This incident affected: GeorgiaBEST Banner Managed Services (Gordon State College, Savannah State University, South Georgia State College).