SYSTEMS STATUS

Microsoft 365 Access Issues Reported

Incident Report for USG Services

Resolved

After monitoring the situation, Information Technology Services (ITS) has confirmed the stability of Microsoft 365 Authentication. The system should continue operating normally.

In the event that you experience any further issues with Microsoft 365 Authentication, please contact the USG Service Desk at support@usg.edu or 877-251-2644.
Posted Mar 03, 2025 - 08:15 EST

Monitoring

Microsoft experienced issues with service disruption for all Microsoft 365 services. Microsoft has identified a recent code change to a portion of service infrastructure that they suspect is causing impact. They have reverted the code change, and are monitoring service health telemetry to confirm if the reversion is returning service to expected functionality.

Updates will be posted here as they become available.
Posted Mar 01, 2025 - 17:09 EST
This incident affected: Internal USO Services (USO Email and Calendar, USO SharePoint / OneDrive, USO Teams, USO Telephone System, USO Corporate Applications) and PeachNet Network (Georgia Archives, USO Athens Office, USO Atlanta Office, USO Georgia Film Academy, USO Shared Services Center).