SYSTEMS STATUS

Intermittent Issues with Single Sign On (SSO)

Incident Report for USG Services

Resolved

Systems Support Services (SSS) has confirmed that intermittent issues with Single Sign On (SSO) has been resolved.

In the event that you experience any further issues with Single Sign On (SSO) authentication, please contact the USG Service Desk at support@usg.edu or 877-251-2644.
Posted Feb 27, 2026 - 11:16 EST

Investigating

Systems Support Services (SSS) is investigating reports of intermittent issues with Single Sign On (SSO). Users may experience problems accessing applications that use Single Sign On (SSO) authentication.

We will provide an update as soon as more information is available.
Posted Feb 26, 2026 - 15:46 EST
This incident affected: Internal USO Services (USO SSO).