SYSTEMS STATUS

Multi-site Windstream Outage

Incident Report for USG Services

Resolved

Service has been fully restored at all of these locations.

If you have any questions or concerns, please reach out to the USG Service Desk at support@usg.edu or call 877-251-2644.
Posted Jun 26, 2026 - 08:19 EDT

Investigating

There is a multi-site outage affecting the following locations:

Pataula Charter
Schley County
Southwest GA STEM
Terrell County

ENA/Zayo is currently investigating, but we do not have an ETR at this time.
Posted Jun 25, 2026 - 07:51 EDT
This incident affected: GA DOE K-12 Network.