SYSTEMS STATUS
USG Technology Store Issues Reported
Incident Report for USG Services
Resolved
Information Technology Services (ITS) has confirmed that the USG Technology Store (techstore.usg.edu) is functioning normally at this time.

In the event that you experience any further issues with the USG Technology Store, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted Mar 26, 2020 - 09:33 EDT
Investigating
The USG Technology Store is currently experiencing technical issues and is off-line at this time. USG Support Staff are currently working with the vendor to resolve and mitigate this issue.

Additional information will be posted here as it becomes available.
Posted Mar 25, 2020 - 13:55 EDT
This incident affected: USG Technology Store.