SYSTEMS STATUS
Power Outage - University Of West Georgia
Incident Report for USG Services
Resolved
The University of West Georgia's power has been restored and services should be functional.
Posted Dec 30, 2024 - 09:42 EST
Update
Georgia Power has an ERT (estimated restoration time) of Monday, December 30, 2024, at 9:00 a.m.
Posted Dec 30, 2024 - 08:34 EST
Investigating
The University of West Georgia is currently without power due to the power company working on a power substation nearby. No information as to how long it will last.
Posted Dec 30, 2024 - 08:25 EST
This incident affected: PeachNet Network (University of West Georgia).