SYSTEMS STATUS
GeorgiaBEST Managed Services Issue Reported - Fort Valley State University
Incident Report for USG Services
Resolved
After monitoring the situation, Information Technology Services (ITS) has confirmed the stability of GeorgiaBEST Managed Services. The system should continue operating normally.

In the event that you experience any further issues with GeorgiaBEST Managed Services, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted May 22, 2023 - 16:30 EDT
Monitoring
Full functionality of GeorgiaBEST Managed Services at Fort Valley State University has been restored. We will continue to monitor this system for stability. If you are still experiencing issues with GeorgiaBEST Managed Services, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted May 19, 2023 - 09:57 EDT
Investigating
Information Technology Services (ITS) is currently investigating reports of issues with GeorgiaBEST Managed Services.
Affected users may be experiencing issues logging into Banner. Additional information will be posted here when the issues are confirmed.
Posted May 19, 2023 - 09:52 EDT
This incident affected: GeorgiaBEST Banner Managed Services (Fort Valley State University).