All reported incidents with Degree Works hosted in Ellucian Cloud are resolved.
In the event that you experience any further issues accessing Banner Managed Services - Degree Works, please contact the USG Service Desk at support@usg.edu or 877-251-2644.
Posted Mar 10, 2026 - 11:07 EDT
Monitoring
All reported incidents with Degree Works hosted in Ellucian Cloud are resolved. However, Information Technology Services (ITS) will continue to monitor campus operations to ensure there will be no additional occurrences.
In the event that you experience any further issues accessing Banner Managed Services - Degree Works, please contact the USG Service Desk at support@usg.edu or 877-251-2644.
Posted Mar 09, 2026 - 13:40 EDT
Investigating
Information Technology Services (ITS) is investigating reports that Degree Works Cloud Services are down for all Degree Works Cloud hosted institutions. Disruption of one or more components has been reported to the Helpdesk and/or confirmed by ITS staff. Technical teams are being engaged. An additional update will be provided once an investigation has been completed.
Posted Mar 09, 2026 - 12:04 EDT
This incident affected: GeorgiaBEST Degree Works Managed Services (Abraham Baldwin Agricultural College, Albany State University, Atlanta Metropolitan State College, College of Coastal Georgia, Columbus State University, Dalton State College, Fort Valley State University, Georgia Gwinnett College, Georgia Southwestern State University, Middle Georgia State University, Savannah State University, South Georgia State College).