SYSTEMS STATUS

USO Conference Room Closure - Trinity Washington - Room 6050 Technology

Incident Report for USG Services

Resolved

Trinity Washington Room 6th floor Room 6050 Technology repairs have been completed and the conference room is now open.
Posted Jun 02, 2023 - 15:49 EDT

Identified

Trinity Washington Room 6th floor Room 6050 Technology is not working and is scheduled for repair.
Posted May 31, 2023 - 16:46 EDT
This incident affected: Internal USO Services (USO Conference Rooms/Classrooms).