SYSTEMS STATUS

Issues with Reporting for GeorgiaFIRST Financials

Incident Report for USG Services

Resolved

After monitoring the situation, Information Technology Services (ITS) has confirmed the stability of GeorgiaFIRST Financials. The system should continue operating normally.

In the event that you experience any further issues with email notifications, please contact the USG Service Desk at support@usg.edu or 877-251-2644.
Posted Mar 14, 2025 - 14:48 EDT

Update

Information Technology Services (ITS) has restored full functionality of email notifications. We will continue to monitor this system for stability. If you are still experiencing issues with email notifications, please contact the USG Service Desk at support@usg.edu or 877-251-2644.
Posted Mar 12, 2025 - 09:54 EDT

Monitoring

Information Technology Services (ITS) has restored full functionality of email notifications. We will continue to monitor this system for stability. If you are still experiencing issues with email notifications, please contact the USG Service Desk at support@usg.edu or 877-251-2644.
Posted Mar 12, 2025 - 08:49 EDT

Investigating

Information Technology Services (ITS) is currently investigating reports of notifications and reports not being emailed as expected from GeorgiaFIRST Financials. Additionally, we are aware of issues with accessing reports in Report Manager.

We appreciate your patience as we work to resolve these matters.
Posted Mar 11, 2025 - 12:22 EDT
This incident affected: GeorgiaFIRST Financials (GeorgiaFIRST PeopleSoft Financials).