SYSTEMS STATUS
GIL Express Courier Service Schedule
Incident Report for USG Services
Resolved
GIL Express Courier Service will resume normal delivery and pickup on Tuesday, September 6th, 2016.
Posted Sep 02, 2016 - 16:59 EDT
Identified
Due to inclement weather conditions, GIL Express Courier Service may not make deliveries or pickups in certain locations on Friday, September 2, 2016.

Locations Affected:

- Abraham Baldwin Agriculture College
- Albany State University
- Bainbridge College
- Darton College
- South Georgia State College (Waycross Campus)
- University of Georgia (Tifton Campus)
- Valdosta State University
Posted Sep 02, 2016 - 08:43 EDT
This incident affected: GALILEO - Georgia's Virtual Library (GIL Express).